electron/Information 2016.09.26 14:59

electron 0.33.3 버전때 까지 잘 사용해오던 electron-packager...


electron 1.4.1 때 장난 삼아 만든 앱을 패키징 하려고 하는데....


갑자기 안된다?


왜지?


물론 electron-packager도 5.1.1 에서 8.0.0 으로 업뎃이 되긴했다만...


왜 잘되던게 안되는거지?


구글링도 해보고 이것저것 다해보았지만 아무런 반응이 없다...


electron binary를 받아서 패키징을 해야할텐데..


왜 아무 반응이 없지!!!!!


짜증이 막 칠라는 순간.... electron-packager 가 업뎃이 되면서 여러 옵션들이 생겼다.


아무래도 이 옵션들이 생기면서 윈도우에서 꼬이게 된거 같은 느낌이 든다.


그래서 하나씩 테스트 해본 결과


tmpdir 이라는 옵션이..... 문제였다. (이유였다? 여튼..) 


tmpdir=false 로 주고 임시 디렉토리를 비활성화 시키니까 된다....


아이고 환장하겄네ㅜㅜ